Clirr Results

The following document contains the results of Clirr.

  • Current Version: 4.5.3
  • Comparison Version: 4.4

Summary

SeverityNumber
Error Error0
Warning Warning0
Info Info4

API Incompatibilities

SeverityMessageClassMethod / Field
InfoAccessibility of method 'Content(byte[], org.apache.http.entity.ContentType)' has been increased from package to publicorg.apache.http.client.fluent.ContentContent(byte[], org.apache.http.entity.ContentType)
InfoMethod 'public org.apache.http.client.fluent.Executor cookieStore(org.apache.http.client.CookieStore)' has been deprecatedorg.apache.http.client.fluent.Executorpublic org.apache.http.client.fluent.Executor cookieStore(org.apache.http.client.CookieStore)
InfoMethod 'public org.apache.http.client.fluent.Executor use(org.apache.http.client.CredentialsProvider)' has been addedorg.apache.http.client.fluent.Executorpublic org.apache.http.client.fluent.Executor use(org.apache.http.client.CredentialsProvider)
InfoMethod 'public org.apache.http.client.fluent.Executor use(org.apache.http.client.CookieStore)' has been addedorg.apache.http.client.fluent.Executorpublic org.apache.http.client.fluent.Executor use(org.apache.http.client.CookieStore)

API Changelog

The following APIs were modified from version 4.4 to 4.5.3:
  • Non justified changes

    ClassFromTo
    org.apache.http.client.fluent.ContentContent(byte[], org.apache.http.entity.ContentType)
    org.apache.http.client.fluent.Executorpublic org.apache.http.client.fluent.Executor cookieStore(org.apache.http.client.CookieStore)
    org.apache.http.client.fluent.Executorpublic org.apache.http.client.fluent.Executor use(org.apache.http.client.CookieStore)
    org.apache.http.client.fluent.Executorpublic org.apache.http.client.fluent.Executor use(org.apache.http.client.CredentialsProvider)